Integrationen

Figma (Strings)

Inhalte werden von Phrase Language AI maschinell aus dem Englischen übersetzt.

Verfügbar für

  • Alle bezahlten Pläne

Verfügbar für

  • Advanced- und Enterprise-Plan (Legacy)

Kontaktiere Vertrieb für Fragen zur Lizenzierung.

Tipp

Informationen zur Figma-Integration in Phrase TMS sind unter Figma (TMS) zu finden.

Das Figma-Plug-in ermöglicht die Integration von Design-Content in Phrase-Projekte und schließt die Lücke zwischen Produktdesign- und Lokalisierungsteams. Das Plug-in unterstützt das Übertragen von Content, das Abrufen von Übersetzungen und die Verwaltung von Schlüsseln zwischen Figma und Phrase Strings.

  • Branching wird unterstützt.

  • Der Zugriff auf mindestens ein Projekt und eine Sprache mit Übersetzer-Benutzerrechten ist erforderlich. Der Zugriff kann gewährt werden, indem eine invitation von einem Administrator or Project manager versendet wird.

  • Das Plug-in sendet Screenshots von Auto-Layout-Frames, die kein untergeordnetes Element sind.

  • Standardmäßig sind ausgeblendete Textebenen nicht in der Integration enthalten. Dies kann in den Einstellungen Setup_gear.png durch Auswählen von Include hidden layers or frames in selection geändert werden.

  • Standardmäßig werden ausgewählte Tags im Plug-in nach dem Push-Vorgang gelöscht. Dies kann in den Einstellungen Setup_gear.png durch Deaktivieren der Option Clear tags after push geändert werden.

  • Alle Änderungen an den Standardeinstellungen Setup_gear.png des Plug-ins werden gespeichert und bleiben dauerhaft erhalten.

Installieren und Verbinden des Figma Plug-ins

Um das Plug-in auszuführen, kann es im Figma-Plug-in-Browser oder in der Figma Community ausgewählt und anschließend auf Try it out geklickt werden. Das Plug-in ist dann im Figma-Menü Plugins verfügbar.

Die Verbindung von Figma zu Phrase kann mit Phrase-Anmeldeinformationen, einem access token oder Single Sign-On (SSO) hergestellt werden.

Anmeldung mit SSO:

  1. Auf dem Anmeldebildschirm des Plug-ins ist Sign in with SSO auszuwählen.

  2. Die Organisation-ID eingeben.

  3. Die Anmeldung im sich öffnenden Browser-Tab abschließen.

    Zum Plug-in zurückkehren, bereits authentifiziert.

Wenn die Verbindung hergestellt ist, lädt das Auswählen eines Frames eine Vorschau des Figma-Contents und der Keys, die Benutzer an Phrase Strings übertragen oder von dort abrufen können.

Der Tab Connect keys ermöglicht das Verbinden von Figma-Ebenen mit Keys, die bereits in einem Strings Projekt existieren. Wenn die Namenskonvention sowohl für die Ebenen als auch für die Keys gleich ist, können sie automatisch abgeglichen werden.

Das Plug-in ist über dedizierte Schaltflächen in der Figma-Seitenleiste zugänglich:

  • Phrase Strings

    Zum Öffnen des Plug-ins klicken.

  • View text in Strings

    Wird in Figma-Dateien angezeigt, die mit einem Strings-Projekt verbunden sind. Zum Öffnen des entsprechenden Projekts im Translation Editor klicken.

Content übertragen

Der Tab Push content to Phrase ermöglicht das Senden von Frames oder Textebenen aus Figma an Phrase Strings zur Lokalisierung. Es ist nicht möglich, Content in einen geschützten Haupt-Branch zu übertragen.

Das Projekt, den Branch (falls verwendet) und die Sprache für den zu übertragenden Content auswählen. Optional einen individuellen Tag eingeben, der den hochgeladenen Keys hinzugefügt wird.

Leere oder doppelte Key-Namen werden mit einem roten Zähler in der Content-Spalte markiert. Um lange Listen von Key-Namen zu verwalten, das Dropdown-Menü Sort by Sort Filter verwenden, um Unvollständige Key-Namen zuerst oder Doppelte Key-Namen zuerst anzuzeigen.

Hinweis

Die gewählte Sortieroption wird für zukünftige Sitzungen gespeichert.

Die Schaltfläche Push to Phrase ist deaktiviert, wenn Key-Name-Eingaben leer sind, ungültige Zeichen enthalten oder nicht eindeutig sind, falls ein geschützter Haupt-Branch ausgewählt ist.

Die Einstellung Work with key names auswählen, um Key-Name-Eingaben zu bearbeiten und Namenskonflikte zu beheben. Bei Bedarf die gewünschten Keys auswählen und oben in der Tabelle auf Layer ausschließen klicken, um diese Layer aus dem Plug-in zu entfernen.

Wenn es getrennte Layer mit widersprüchlichen Key-Namen gibt, ist eine der verfügbaren Auflösungsoptionen auszuwählen, um fortzufahren:

  • Key-Kopien in Phrase Strings erstellen

    Erstellt neue Keys mit dem Suffix -copy.

  • Mit vorhandenen Keys verbinden

    Verknüpft Layer mit vorhandenen Phrase-Keys.

  • Widersprüchliche Keys nicht pushen

    Pusht nur nicht widersprüchliche Layer.

Wenn die Option Figma-Vorschau hochladen aktiviert ist:

  • Benutzer können optional auswählen, welche Zielsprachen in die Figma-Vorschau aufgenommen werden sollen. Wenn keine Sprachen ausgewählt sind, werden standardmäßig alle Sprachen einbezogen.

  • Das Plug-in erstellt einen Job pro Root-Frame (oder Top-Level-Komponente), der im Push enthalten ist. Das Pushen einer gesamten Figma-Seite mit vielen Top-Level-Frames generiert eine entsprechend große Anzahl an Jobs. Um die Job-Anzahl proportional zum tatsächlichen Umfang der Übersetzungsarbeit zu halten, sollten vor dem Pushen nur die spezifischen Frames ausgewählt werden, die neuen oder aktualisierten Content enthalten.

Wenn Layer erfolgreich an Strings übertragen wurden, wird das Fenster Push abgeschlossen mit einer Zusammenfassung und den folgenden Optionen angezeigt:

  • erstellen Job

    Die Seite Job erstellen mit den bereits ausgewählten Keys kann durch einen Klick geöffnet werden.

    Wichtig

    Wenn die Option Figma-Vorschau hochladen aktiviert ist, wird automatisch ein Job in Strings erstellt. Sobald dies aktiviert ist, kann es nicht mehr deaktiviert werden.

  • In Strings öffnen

    Zum Anzeigen der gepushten Keys im Strings Editor hier klicken.

Ein gelbes Warnung-Symbol Warning erscheint neben Keys, deren Namen in Strings nach dem Pushen von Content geändert wurden. Um Key-Namen im Figma-Plug-in zu aktualisieren, kann im Ellipsen-Menü More Menu neben dem nicht übereinstimmenden Key-Namen die Option Sync key name ausgewählt werden.

Push-Optionen und Aktionen

Über das Menü View options More Menu können die folgenden Push-Optionen bei Bedarf ein- oder ausgeschaltet werden:

  • Upload screenshots ist standardmäßig aktiviert. Dies ermöglicht das Anhängen eines Screenshots der ausgewählten Layer innerhalb des Frames:

    • Wenn die Einstellung Include hidden layers or frames in selection aktiviert ist, erhalten ausgeblendete Text-Layer, die mit dem Figma-Plug-in importiert wurden, einen Marker in der oberen linken Ecke des Screenshots.

    • Wenn die Einstellung Exclude sections from screenshots aktiviert ist, werden keine Screenshots von Figma-Sektionen erstellt.

      Es wird empfohlen, diese Option bei Performanceproblemen mit dem Plug-in während der Arbeit innerhalb von Sektionen aktiviert zu lassen.

    • Durch Aktivierung von Capture only the closest screenshot wird jeder Screenshot auf den nächstgelegenen umschließenden Frame, die Komponente, Instanz oder Sektion eines Text-Layers begrenzt, anstatt auf das äußerste übergeordnete Element. Alle Text-Layer innerhalb dieses Containers erhalten Marker, einschließlich der Layer außerhalb der aktuellen Auswahl.

      Diese Option ist standardmäßig deaktiviert. Die Option sollte genutzt werden, wenn Exclude sections from screenshots die Erfassung nicht ausreichend auf einen bestimmten verschachtelten Frame begrenzt, sodass übergroße, kontextarm wirkende Screenshots entstehen.

  • Update content in Phrase Strings ist standardmäßig aktiviert.

  • Update key names in Phrase Strings ist standardmäßig aktiviert, es sei denn, die Einstellung Work with key names in Figma ist deaktiviert.

    Das Deaktivieren dieser Option setzt alle Key-Name-Eingaben zurück.

  • Aktivieren Sie Upload Figma preview, um ein HTML-Paket aus den ausgewählten Keys zu exportieren.

    Diese Option ist erforderlich, um eine in-context preview im CAT Editor des TMS zu generieren, wenn mit jobs synced aus Strings gearbeitet wird.

    Benutzer können optional auswählen, welche Zielsprachen in der Figma-Vorschau einbezogen werden sollen, wenn Inhalte übertragen werden. Wenn keine Sprachen ausgewählt sind, werden standardmäßig alle Sprachen einbezogen.

    Wenn die Vorschau erfolgreich generiert wurde, wird automatisch ein Job in Strings erstellt. Jede aktive Job-Automatisierung im Strings-Projekt wird übersprungen, um doppelte Jobs zu vermeiden.

    Wenn die Vorschau das 10-MB-Limit überschreitet, werden die Keys zwar an Strings übertragen, aber es wird kein Job mit einer Vorschau erstellt.

    Hinweis

    Zum Arbeiten mit Figma-Vorschauen im Strings Editor kann die Aktion Figma-Vorschau hinzufügen in der kontextbezogenen Seitenleiste verwendet werden.

  • Content-Formatierung & Styling beibehalten aktivieren, um Rich-Text-Formatierungen (wie Listen, Zeilenumbrüche, Fett/Kursiv und Links) beizubehalten, wenn Content von Figma an Phrase übertragen und Übersetzungen zurückgezogen werden.

    Wenn diese Option aktiviert ist, werden HTML-Formatierungstags automatisch hinzugefügt, um das Inline-Styling zu bewahren, und sie werden in der In-Context-Vorschau des TMS unterstützt, wenn mit aus Strings synchronisierten Jobs gearbeitet wird. Die HTML-Formatierungs-Tags erscheinen im Strings Editor und in exportierten Übersetzungen, die zurück in Figma gezogen werden.

    Diese Option deaktivieren, wenn keine Rich-Formatierung erforderlich ist, um manuelle Anpassungen zu vermeiden.

    Die Einstellung gilt auf Dateiebene und betrifft alle Mitarbeiter, die in der Datei arbeiten. Diese Option wird für neue Dateien gespeichert.

Für verbundene Ebenen stehen im entsprechenden Ellipsen-More Menu-Menü folgende Aktionen zur Verfügung:

  • Mittels Key-Details anzeigen kann die Key-Beschreibung in Phrase Strings angesehen und bearbeitet oder ein Zeichenlimit für den Key festgelegt werden. Alle im Fenster Key-Details gespeicherten Änderungen erscheinen nach dem Aktualisieren der Editor-Seite in der Strings Editor-Seitenleiste.

    Tipp

    Mehrere Keys im Tab Content an Phrase übertragen auswählen und die Batch-Aktion Zeichenlimit festlegen verwenden, um ein Zeichenlimit für alle ausgewählten Keys gleichzeitig festzulegen.

  • Key im Editor öffnen auswählen, um zum entsprechenden Key im Strings Editor zu navigieren.

  • Content von Phrase Strings trennen auswählen, um die Ebene von einem bestehenden Key zu trennen.

Duplizierten Content verwalten

Beim Übertragen von Inhalten generieren Ebenen mit dupliziertem Inhalt mehrere Keys in Strings, die exakt denselben Text enthalten. Im Fenster Content an Phrase übertragen kann festgelegt werden, wie duplizierter Inhalt verwaltet werden soll:

  • Mittels Ohne Zusammenführung fortfahren kann fortgefahren werden, wenn das Erstellen mehrerer Keys mit dupliziertem Inhalt beabsichtigt ist.

  • Um duplizierten Inhalt in einem einzigen Key zusammenzuführen, sind folgende Schritte auszuführen:

    1. Zwei oder mehr Keys aus der Liste auswählen und auf Merge Merge to a key... klicken.

      Ein Dropdown-Menü mit verfügbaren Keys zum Zusammenführen wird angezeigt.

    2. Es sollte der Key ausgewählt werden, in den der duplizierte Inhalt zusammengeführt werden soll.

      Der ausgewählte Key ist im Push content to Phrase Fenster mit einem blauen zusammenführen-Symbol Merge to a Key markiert.

    3. Auf Proceed klicken und anschließend durch Auswählen von Merge and Push im Popup Merge duplicated content bestätigen.

      Der duplizierte Content wird in einem einzigen Key zusammengeführt und alle zugehörigen Ebenen werden mit diesem Key verbunden.

  • Um einen Teil oder den gesamten duplizierten Inhalt in den ersten Key der Liste zusammenzuführen, sind folgende Schritte auszuführen:

    1. Es sind mehrere oder alle Keys aus der Liste auszuwählen und anschließend auf Merge Merge all duplicates into first key zu klicken.

    2. Klicken Sie auf Proceed und bestätigen Sie dann durch Auswählen von Merge and Push im Merge duplicated content Popup.

      Der duplizierte Content wird in einem einzigen Key zusammengeführt und alle zugehörigen Ebenen werden mit diesem Key verbunden.

    Diese Option ist nützlich für große Dateien mit vielen Duplikaten und ermöglicht es Benutzern, alle Duplikate in einer einzigen Aktion in den ersten gefundenen Key zusammenzuführen, anstatt jeden einzeln zu bearbeiten.

Das Duplizieren eines Frames oder einer Textebene in Figma dupliziert auch jede bestehende Verbindung zu einem Phrase Strings Key. Wenn die duplizierte Ebene für neuen, unabhängigen Text wiederverwendet und ohne vorherige Trennung übertragen wird, aktualisiert der Push den Quelltext des bestehenden Keys, anstatt einen neuen zu erstellen. Das Aktualisieren des Quelltexts eines Keys löscht oder aktualisiert nicht die bereits auf diesem Key gespeicherten Übersetzungen in der Zielsprache. Wird die Ebene danach abgerufen, erscheint die Übersetzung, die mit dem vorherigen Inhalt verknüpft war, statt der neu übertragenen Version.

Bevor Inhalte von einem duplizierten oder wiederverwendeten Frame oder einer Textebene übertragen werden, sollte der Push content to Phrase Tab überprüft werden, um festzustellen, ob die Ebene bereits mit einem Key verbunden ist. Falls eine Verbindung besteht und der neue Text nichts mit dem vorherigen Inhalt zu tun hat, sollte die Ebene zuerst getrennt werden, damit das Plug-in einen neuen Key erstellt, anstatt den bestehenden zu überschreiben.

Ebenen automatisch ausschließen

Die Einstellung Auto-exclude layers entfernt Textebenen basierend auf ihrem Namenspräfix aus dem Push content to Phrase Tab. Wenn diese aktiviert ist, wird jede Ebene, die mit _ oder . beginnt, automatisch ausgeschlossen.

Die Einstellung ist standardmäßig deaktiviert und gilt pro Datei. Die Einstellung gilt für alle benannten Ebenen in der Datei, bis sie deaktiviert wird.

Ausschlüsse bleiben über Auswahlen hinweg bestehen. Bei Komponenten erben nachgelagerte Designs, die diese Komponente verwenden, den Ausschluss, wenn die Ebenen der Komponente mit einem Präfix versehen sind und Ebenen automatisch ausschließen aktiviert ist.

Um mit einem Präfix versehene Ebenen automatisch von Push auszuschließen:

  1. In Figma werden Textebenen, die ausgeschlossen werden sollen, mit dem Präfix _ oder . versehen. Dies kann auch in einem Batch durchgeführt werden.

  2. Die Plug-in-Einstellungen öffnen und Ebenen automatisch ausschließen aktivieren.

Key-Benennung konfigurieren

Der Bereich Key-Benennung in den Plug-in-Einstellungen Setup_gear.png ermöglicht das Einrichten der Benennungskonvention für verbundene Keys.

Um Key-Namen in Figma anzupassen, sind folgende Schritte zu befolgen:

  1. Über die Key-Benennung-Einstellungen kann durch Klicken auf Smart Key Naming aktivieren die Smart-Key-Naming-Funktion aktiviert werden.

  2. Beim Arbeiten mit Key-Namen in Figma kann Mit Key-Namen in Figma arbeiten ausgewählt werden.

    Hinweis

    Wenn Textebenennamen mit Keys synchronisieren aktiviert ist, werden Key-Namen automatisch basierend auf den Namen der Textebenen generiert.

  3. Im Feld Key-Namensgenerierung kann Text eingegeben werden, um eine individuelle Key-Benennung festzulegen:

    • Optional kann auf Verfügbare Makros geklickt werden, um eines der unterstützten Makros auszuwählen, das Key-Namen automatisch generiert.

      Es können mehrere Makros ausgewählt werden, um den Key-Namen zusammenzusetzen.

    • Es ist möglich, freien Text und Makros im Feld Key-Namensgenerierung zu kombinieren.

      Durch Klicken auf Beispiele werden die vordefinierten Beispiele angezeigt, aus denen ausgewählt werden kann.

  4. Falls erforderlich, kann aus dem Dropdown-Menü Formatierungskonvention eine Formatierungsoption ausgewählt werden, um den Text anzupassen und Leerzeichen zu entfernen.

Beim Übertragen von Inhalten zu Phrase Strings kann die neu erstellte Benennungskonvention auf zuvor verbundene Keys angewendet werden, indem entweder:

  • Das Aktualisieren-Refresh List-Symbol unten in der Tabelle anklickt wird.

  • Es können bestimmte Keys ausgewählt und anschließend oben in der Tabelle Key-Namen neu generieren angeklickt werden.

Verfügbare Makros

Makro

Beschreibung

{file_name}

Der Name der Figma-Datei

{page}

Die Figma-Seite, auf der der Key identifiziert wird

{parent_section}

Der Abschnitt der höchsten Ebene im Seitenbaum

{nearest_section}

Der Abschnitt, der sich am nächsten zur Textebene im Seitenbaum befindet

{frame}

Der Frame, in dem der Key identifiziert wird

{parent_group}

Die Gruppe der höchsten Ebene im Seitenbaum

{nearest_group}

Die Gruppe, die sich am nächsten zur Textebene im Seitenbaum befindet

{component}

Der Name der Figma-Komponente, in der sich der Key befindet. Es werden nur Quellkomponenten berücksichtigt.

{element_name}

Der Name der Textebene

{element_content}

Der Content aus der Textebene

{random}

Ein zufällig generierter, eindeutiger kurzer Hash

Keys verbinden oder trennen

Beim Pushen von Content können Benutzer Ebenen mit vorhandenen Keys in Phrase Strings verbinden oder neue erstellen.

Den Tab Connect keys auswählen, um eine Übersicht der verbundenen und getrennten Keys anzuzeigen.

Keys, die bereits verbunden sind, werden mit einem Link-Connected Key-Symbol in der Spalte Key name gekennzeichnet. Bei Bedarf das Projekt, den Branch (falls verwendet) und die Sprache auswählen oder auf das Suchsymbol klicken, um den gewünschten Content zu finden.

Connect keys auswählen, um alle nicht verknüpften Keys im Tab gebündelt zu verbinden. Um einzelne Keys zu verbinden oder zu trennen, auf das entsprechende Symbol rechts neben dem jeweiligen Eintrag klicken.

Hinweis

Die Option zum Trennen einzelner Keys ist auch im Tab Push content to Phrase verfügbar.

Neue Connect-Ansicht (Beta)

Die neue Ansicht listet Textebenen aus der aktuellen Auswahl mit ihrem Verbindungsstatus in einer einzigen Tabelle auf und ersetzt die bisherige Key-basierte Liste.

Hinweis

Das Plug-in sollte neu gestartet werden, bevor die Beta aktiviert wird, um sicherzustellen, dass die neueste Version geladen ist.

Um die New connect view zu aktivieren:

  1. Das Plug-in öffnen und auf das Symbol Settings klicken.

  2. Unter Plugin settings die Option Use new connect view (Beta) aktivieren.

  3. Connect keys öffnen, um die Liste der verbundenen Inhalte anzuzeigen.

Die vorherige Connect-Ansicht bleibt verfügbar. Use new connect view in den Plug-in-Einstellungen deaktivieren, um dies rückgängig zu machen.

Um eine einzelne Ebene zu verbinden, diese auswählen, um ein Fenster mit zwei Tabs zu öffnen:

  • Suggestions: zeigt Keys mit exakten Namensübereinstimmungen und Keys mit passendem Inhalt an.

  • Search: alle Keys nach Name oder Inhalt durchsuchen.

Um mehrere Ebenen gleichzeitig zu bearbeiten, diese auswählen, um eine Batch-Aktionsleiste anzuzeigen:

  • Connect by key name: verbindet Ebenen mit Keys bei exakten Namensübereinstimmungen.

  • Connect by content: verbindet Ebenen mit Keys bei passendem Inhalt.

  • Disconnect layers: Verbindungen von den ausgewählten Ebenen entfernen.

Ebenen mit mehreren passenden Keys überspringen

Der Schalter Ebenen mit mehreren passenden Keys überspringen steuert, wie Connect by content Ebenen behandelt, deren Text mit mehr als einem Key übereinstimmt.

Um den Schalter zu aktivieren:

  1. Das Plug-in öffnen und zum Tab Connect wechseln.

  2. In der Navigation auf More Menu klicken, um die Ansichtsoptionen zu öffnen.

  3. Ebenen mit mehreren passenden Keys überspringen aktivieren.

Wenn diese Option aktiviert ist, wird jede Ebene, die mit mehr als einem Key übereinstimmt, während Connect by content übersprungen und für eine manuelle Überprüfung unverbunden gelassen.

Zusammenfassung nach der Aktion

Nach jedem Batch-Durchlauf von Connect by content oder Connect by key name zeigt ein Ergebnisfenster das Resultat an:

  • Anzahl verbunden

  • Übersprungen – kein Match gefunden

  • Übersprungen – mehrere Übereinstimmungen (wird angezeigt, wenn „Ebenen mit mehreren passenden Keys überspringen“ aktiviert ist)

Auf Show unconnected layers klicken, um die Tabelle zu filtern, sodass nur Ebenen angezeigt werden, die noch Aufmerksamkeit erfordern, oder auf Done klicken, um das Ergebnisfenster zu schließen.

Plural-Keys verwalten

Das Markieren einer Textebene als Plural-Key verbindet sie mit den Pluralformen dieses Keys in Phrase Strings. Für einen Plural-Key zeigt die Spalte Content ein Dropdown-Menü zur Formauswahl anstelle des Contents des Keys an, in dem die für die ausgewählte Sprache verfügbaren Formen aufgelistet sind, zum Beispiel one und other. Sprachen mit komplexeren Pluralregeln, wie Polnisch, weisen bis zu fünf Formen auf.

Das Dropdown-Menü erscheint sowohl im Tab Push content to Phrase als auch im Tab Pull content to Figma.

So zeigen Sie eine Pluralform auf der Arbeitsfläche in der Vorschau an:

  1. In der Content-Tabelle den Plural-Key ausfindig machen.

  2. Auf das Dropdown-Menü zur Formauswahl in der Spalte Content klicken und die gewünschte Pluralform zur Vorschau auswählen.

  3. Phrase Strings zieht die passende Übersetzung in die Ebene, um sie auf der Arbeitsfläche in der Vorschau anzuzeigen

Das Pushen eines Plural-Keys zu Phrase Strings folgt demselben Push-Workflow wie jeder andere Key und aktualisiert nur die Übersetzung für die ausgewählte Form.

Die ausgewählte Pluralform wird pro Ebene, pro Projekt und Branch gespeichert. Die Auswahl bleibt über Sitzungen hinweg bestehen.

Übersetzungen ziehen

Sobald die Übersetzungen abgeschlossen sind, können die Figma-Ebenen oder -Frames ausgewählt werden, für die Übersetzungen gezogen werden sollen, und der Tab Pull content to Figma kann angeklickt werden.

Es können das Projekt, der Branch (falls verwendet) und die Sprachen für den zu ziehenden Inhalt ausgewählt werden. Tags können nicht zurück nach Figma gezogen werden.

Um lange Listen von Key-Namen zu verwalten, kann das Dropdown-Menü Sort by Sort Filter verwendet werden, um Incomplete key names first anzuzeigen und mögliche Probleme zu beheben. Bei Bedarf können bestimmte Keys ausgewählt und oben in der Tabelle auf Exclude layers geklickt werden, um diese Ebenen aus dem Plug-in zu entfernen.

Hinweis

Die gewählte Sortieroption wird für zukünftige Sitzungen gespeichert.

Auf das Menü View options More Menu klicken, um auszuwählen, wie der abgerufene Content in Figma angezeigt werden soll.

  • Neue Seite pro Sprache erstellen

    Standardmäßig ausgewählt. Beim Abrufen für mehrere Sprachen wird für jede ausgewählte Sprache eine separate Figma-Seite erstellt, die alle Ebenen der Seite enthält.

    Hinweis

    In Figma Buzz wird die Option Erstelle eine neue Zeile mit übersetztem Inhalt angezeigt.

  • Erstelle eine einzige Seite mit allen Sprachen

    Erstellt eine einzelne neue Seite und platziert den ausgewählten übersetzten Content nebeneinander in sprachspezifischen Spalten. Diese Option konzentriert sich nur auf die aktive Auswahl, anstatt die gesamte Figma-Seite zu duplizieren.

    Empfohlen für große Dateien, um die Abrufleistung zu verbessern und die Dateigröße unnötig zu reduzieren.

  • Text-Ebenen mit Übersetzungen überschreiben

    Die ausgewählten Textebenen werden mit den Übersetzungen überschrieben und im Viewport aktualisiert.

    Diese Option wird beim Abrufen für mehrere Sprachen automatisch deaktiviert.

  • Key-Namen statt Content anzeigen

    Standardmäßig deaktiviert. Wenn aktiviert:

    • Key-Namen werden anstelle des übersetzten Content abgerufen und angezeigt.

    • Das Auswählen einer Sprache für den abgerufenen Content ist nicht mehr möglich.

  • Vorschau des Contents in der ausgewählten Sprache

    Die Einstellung wird für zukünftige Sitzungen gespeichert.

    • Wenn deaktiviert, zeigt die Spalte Content den Content der ausgewählten Ebenen direkt an.

    • Wenn aktiviert, zeigt die Content-Spalte eine Vorschau des Contents in der ausgewählten Sprache für verbundene Ebenen an.

      • Für nicht verbundene Ebenen kann die Option Mit vorhandenen Keys verbinden aktiviert werden, um eine Vorschau in der ausgewählten Sprache anzuzeigen. Wenn ein Key mit demselben Namen in den abgerufenen Daten existiert, wird der Content dieses Keys als Vorschau verwendet.

    Diese Option wird beim Abrufen für mehrere Sprachen automatisch deaktiviert.

  • Mit vorhandenen Keys verbinden

    Es kann gesteuert werden, wie nicht verbundene Ebenen behandelt werden, wenn Daten in Figma gezogen werden. Die Einstellung wird für zukünftige Sitzungen gespeichert.

    • Wenn aktiviert, prüft das System, ob ein Key mit demselben Namen in den abgerufenen Daten existiert.

      Wenn ein Match gefunden wird:

      • Nicht verbundene Ebenen werden mit den passenden Keys verbunden.

      • Der Inhalt der Ebenen wird mit den aus den vorhandenen Keys abgerufenen Inhalten aktualisiert.

    • Wenn deaktiviert, werden nicht verbundene Ebenen nicht aktualisiert, selbst wenn passende Keys in den abgerufenen Daten existieren.

Status nach der Übersetzung prüfen

Die Funktion „Status nach der Übersetzung prüfen“ überprüft, ob die Textebenen in der aktuellen Auswahl bereits Übersetzungen für die ausgewählten Zielsprachen besitzen, bevor der Inhalt nach Figma gezogen wird. Die Prüfung erfolgt für alle verbundenen Keys in der Auswahl.

Um den Status nach der Übersetzung zu prüfen

  1. Im Tab Pull content to Figma die Zielsprachen für die Prüfung auswählen.

  2. Auf die Schaltfläche Check translation klicken.

    Die Seite Translation status zeigt eine Anzahl der übersetzten, teilweise übersetzten und nicht übersetzten Keys in jeder Sprache für die aktuelle Auswahl an.

    Neben einer Sprache wird durch einen Klick auf View details eine Aufschlüsselung der verbundenen Keys für diese Sprache geöffnet. Die Filter All, Translated und Not translated werden verwendet, um die Liste einzugrenzen.

Wenn der Inhalt erfolgreich nach Figma gezogen wurde, wird das Fenster Pull completed mit einer Zusammenfassung der aktualisierten Ebenen angezeigt.

Beim Ziehen für mehrere Sprachen öffnet die Schaltfläche Open key in Editor den Key mit der als Standard festgelegten Ausgangssprache des Projekts.

Hinweis

Wenn eine im Design verwendete Schriftart nicht lokal installiert ist, kann das Plug-in die betroffenen Textebenen nicht mit den abgerufenen Übersetzungen aktualisieren. Wenn dies geschieht, wird die Fehlermeldung „Die Schriftart [X] konnte nicht geladen werden“ angezeigt, wobei [X] der Name der fehlenden Schriftart ist. Alle in dieser Fehlermeldung markierten Schriftarten lokal installieren und den Content anschließend erneut laden.

Figma Buzz

Figma Buzz ist ein Tool, bei dem Markendesigner und Marketingteams im Figma-Ökosystem in großem Maßstab markenkonforme visuelle Assets erstellen können. Es umfasst ein System aus Vorlagen, einen vereinfachten Design-Editor, die massenhafte Erstellung von Assets sowie KI-gestützte Bearbeitung.

Das Phrase Strings-Plugin für Buzz ermöglicht, den Textinhalt direkt in Buzz zu lokalisieren, indem es dieselben Funktionen wie die Figma-Design-Integration bereitstellt:

Hinweis

Eine Live-Vorschau wird nicht unterstützt.

Das Plug-in ist über das Menü Plugins in Buzz verfügbar. Nach der Aktivierung kann es für die zukünftige Verwendung gespeichert und auf das ausgewählte Design angewendet werden, indem es in einem modalen Fenster über die Figma Buzz-Seitenleiste geöffnet wird. Textebenen werden automatisch erkannt und im Plug-in angezeigt.

Der Designinhalt kann dann zur Übersetzung in ein verbundenes Strings-Projekt übertragen werden. Nach der Übersetzung kann der lokalisierte Inhalt zurück in Buzz geladen werden, wodurch eine neue Zeile mit der übersetzten Version des Designs erstellt wird.

Der Schalter Upload Figma preview und die Auswahl der Zielsprache vor dem Übertragen von Schlüsseln sind in Buzz nicht verfügbar. Beim Übertragen von Schlüsseln aus Buzz werden alle im Strings-Projekt konfigurierten Zielsprachen automatisch verwendet.

War dieser Beitrag hilfreich?

Sorry about that! In what way was it not helpful?

The article didn’t address my problem.
I couldn’t understand the article.
The feature doesn’t do what I need.
Other reason.

Note that feedback is provided anonymously so we aren't able to reply to questions.
If you'd like to ask a question, submit a request to our Support team.
Thank you for your feedback.