Intégrations

Figma (Strings)

Le contenu est traduit de l’anglais par Phrase Language AI.

Disponible pour

  • Tous les forfaits payants

Disponible pour

  • Les forfaits Advanced et Enterprise (ancien)

Contactez le service commercial pour toute question relative aux licences.

Astuce

Pour plus d'informations sur l'intégration de Figma dans Phrase TMS, consultez Figma (TMS).

Le plugin Figma permet d’intégrer le contenu des maquettes aux projets Phrase et facilite la collaboration entre les équipes de conception de produits et de localisation. Le plugin prend en charge l'envoi de contenu, l'extraction de traductions et la gestion des clés entre Figma et Phrase Strings.

  • La gestion des branches est prise en charge.

  • L'accès à au moins un projet et une langue avec des droits d'utilisateur Traducteur est requis. L'accès peut être accordé en recevant une invitation envoyée par un administrateur ou un chef de projet.

  • Le plugin envoie des captures d’écran des cadres à mise en page automatique qui ne sont pas des éléments enfants.

  • Par défaut, les calques de texte masqués ne sont pas inclus dans l'intégration. Vous pouvez modifier ce comportement dans les paramètres Setup_gear.png en sélectionnant Inclure les calques ou les cadres masqués dans la sélection.

  • Par défaut, les balises sélectionnées dans le plugin sont effacées après le processus d'envoi. Cela peut être modifié dans les paramètres Setup_gear.png en désactivant l'option Effacer les balises après l'envoi.

  • Toute modification apportée aux paramètres par défaut Setup_gear.png du plugin sera enregistrée et conservée.

Installer et connecter le plugin Figma

Pour exécuter le plugin, sélectionnez-le dans le navigateur de plugins de Figma ou sur Figma Community, puis cliquez sur Essayer. Le plugin sera disponible dans le menu Plugins de Figma.

La connexion de Figma à Phrase peut être établie avec des identifiants Phrase, un jeton d'accès ou par authentification unique (SSO).

Pour se connecter par authentification unique (SSO) :

  1. Sur l'écran de connexion du plugin, sélectionnez Se connecter avec SSO.

  2. Saisissez l'identifiant de l'organisation.

  3. Terminez la connexion dans l'onglet du navigateur qui s'ouvre.

    Revenez au plugin : vous êtes déjà connecté.

Une fois la connexion établie, la sélection d’un cadre affiche un aperçu du contenu Figma et des clés que les utilisateurs peuvent envoyer à Phrase Strings ou récupérer depuis Phrase Strings.

L'onglet Connecter les clés permettra de connecter les calques Figma aux clés existant déjà dans un projet Strings. Si la convention de nommage est la même pour les calques et les clés, ils peuvent être automatiquement mis en correspondance.

Le plugin est accessible via des boutons dédiés dans la barre latérale Figma :

  • Phrase Strings

    Cliquez pour ouvrir le plugin.

  • Voir le texte dans Strings

    Affiché dans les fichiers Figma connectés à un projet Strings. Cliquez pour ouvrir le projet correspondant dans l'éditeur de traduction.

Envoyer le contenu

L’onglet Envoyer le contenu vers Phrase permet d’envoyer des cadres ou des calques de texte de Figma à Phrase Strings en vue de leur localisation. Il n'est pas possible d'envoyer du contenu vers une branche principale protégée.

Sélectionnez le projet, la branche (si utilisée) et la langue pour le contenu envoyé. Vous pouvez également saisir une balise personnalisée à ajouter aux clés envoyées.

Les noms de clés vides ou en double sont signalés par un compteur rouge dans la colonne Contenu. Pour gérer de longues listes de noms de clés, utilisez le menu déroulant Trier par Filtre de tri pour afficher Les noms de clés incomplets en premier ou Les noms de clés en double en premier.

Remarque

L'option de tri sélectionnée sera mémorisée pour les sessions futures.

Le bouton Envoyer vers Phrase est désactivé si les champs de saisie des noms de clés sont vides, contiennent des caractères non valides ou, lorsqu’une branche principale protégée est sélectionnée, comportent des noms de clés en double.

Sélectionnez le paramètre Travailler avec les noms de clés pour modifier les saisies de noms de clés et résoudre tout conflit de nommage. Si nécessaire, sélectionnez les clés souhaitées et cliquez sur Exclure les calques en haut du tableau pour supprimer ces calques du plugin.

S'il existe des calques déconnectés avec des noms de clés en conflit, sélectionnez l'une des options de résolution disponibles pour continuer :

  • Créer des copies de clés dans Phrase Strings

    Crée de nouvelles clés avec le suffixe -copy.

  • Associer aux clés existantes

    Lie les calques aux clés Phrase existantes.

  • Ne pas envoyer les clés en conflit

    Envoie uniquement les calques sans conflit.

Lorsque l'option Téléverser l'aperçu Figma est activée :

  • Les utilisateurs peuvent choisir les langues cibles à inclure dans l'aperçu Figma. Si aucune langue n'est sélectionnée, toutes les langues sont incluses par défaut.

  • Le plugin crée une tâche par cadre racine (ou composant de niveau supérieur) inclus dans l'envoi. L'envoi d'une page Figma entière contenant de nombreux cadres de niveau supérieur générera un nombre de tâches proportionnellement élevé. Pour maintenir le nombre de tâches proportionnel à l'étendue réelle du travail de traduction, sélectionnez uniquement les cadres spécifiques contenant du contenu nouveau ou mis à jour avant l'envoi.

Si les calques sont envoyés avec succès vers Strings, la fenêtre Envoi terminé s'affiche avec un résumé et les options suivantes :

  • Créer une tâche

    Cliquez pour ouvrir la page Créer une tâche avec les clés envoyées présélectionnées.

    Important

    Si l'option Téléverser l'aperçu Figma est activée, une tâche est créée automatiquement dans Strings. Une fois activée, cette option ne peut pas être désactivée.

  • Ouvrir dans Strings

    Cliquez pour afficher les clés envoyées dans l'éditeur de Strings.

Une icône d'avertissement jaune Avertissement apparaît à côté des clés dont les noms ont été modifiés dans Strings après l'envoi du contenu. Pour mettre à jour les noms des clés dans le plugin Figma, sélectionnez Synchroniser le nom de la clé dans le menu à trois points Plus d'options situé à côté du nom de la clé qui ne correspond pas.

Options et actions d'envoi

Cliquez sur le menu Afficher les options Plus d'options pour activer ou désactiver les options d'envoi suivantes selon les besoins :

  • L'option Téléverser des captures d'écran est activée par défaut. Elle permet de joindre une capture d’écran des calques sélectionnés dans le cadre :

    • Si le paramètre Inclure les calques ou cadres masqués dans la sélection est activé, les calques de texte masqués importés avec le plugin Figma auront un marqueur placé dans le coin supérieur gauche de la capture d'écran.

    • Lorsque le paramètre Exclure les sections des captures d’écran est activé, aucune capture d’écran des sections Figma n’est créée.

      Il est recommandé de laisser cette option activée si vous rencontrez des problèmes de performances avec le plugin lorsque vous travaillez dans des sections.

    • Activez Capturer uniquement la capture d’écran la plus proche pour limiter chaque capture d’écran au cadre, composant, instance ou section le plus proche contenant un calque de texte, plutôt qu’à l’ancêtre de plus haut niveau. Tous les calques de texte à l'intérieur de ce conteneur reçoivent des marqueurs, y compris les calques en dehors de la sélection actuelle.

      Cette option est désactivée par défaut. Utilisez-la lorsque Exclure les sections des captures d’écran ne limite pas suffisamment la capture à un cadre imbriqué précis, ce qui produit des captures d’écran trop grandes et offrant peu de contexte.

  • Mettre à jour le contenu dans Phrase Strings est activé par défaut.

  • Mettre à jour les noms des clés dans Phrase Strings est activé par défaut, sauf si le paramètre Travailler avec les noms des clés dans Figma est désactivé.

    La désactivation de cette option réinitialise tous les champs de saisie des noms de clés.

  • Activez Téléverser l’aperçu Figma pour exporter un ensemble de fichiers HTML à partir des clés sélectionnées.

    Cette option est nécessaire pour générer un aperçu en contexte dans l’éditeur de traduction assistée par ordinateur du système de gestion des traductions lorsque vous travaillez sur des tâches synchronisées depuis Strings.

    Lors de l’envoi du contenu, les utilisateurs peuvent, s’ils le souhaitent, choisir les langues cibles à inclure dans l’aperçu Figma. Si aucune langue n'est sélectionnée, toutes les langues sont incluses par défaut.

    Si l'aperçu est généré avec succès, une tâche est créée automatiquement dans Strings. Toute automatisation de tâche active dans le projet Strings sera ignorée pour éviter les tâches en double.

    Si l’aperçu dépasse la limite de 50 Mo, les clés sont tout de même envoyées à Strings, mais aucune tâche accompagnée d’un aperçu n’est créée.

    La génération de l’aperçu nécessite des nœuds de type conteneur, tels que des cadres, des groupes, des sections ou des composants, contenant des calques de texte imbriqués. Les nœuds constitués uniquement de formes, tels que les rectangles, ne peuvent pas contenir de calques de texte. Les inclure dans la sélection lors d’un envoi avec l’option Téléverser l’aperçu Figma activée déclenche donc un avertissement : « Impossible de téléverser l’aperçu interactif pour le nœud [NODE]... Les calques de texte de ce cadre n’ont pas été inclus dans l’envoi en cours. » Cet avertissement n’a aucune incidence sur l’envoi du contenu lui-même. Les clés et les traductions des calques de texte sélectionnés sont néanmoins envoyées à Phrase Strings. Vous pouvez ignorer cet avertissement. Pour éviter cet avertissement, excluez de la sélection les nœuds constitués uniquement de formes et ne contenant aucun calque de texte imbriqué avant d’envoyer le contenu.

    Remarque

    Pour utiliser les aperçus Figma dans l’éditeur Strings, sélectionnez l’action Ajouter un aperçu Figma dans la barre latérale contextuelle.

  • Activez Préserver la mise en forme et le style du contenu pour conserver la mise en forme du texte enrichi (notamment les listes, les sauts de ligne, le gras, l’italique et les liens) lorsque vous envoyez du contenu de Figma vers Phrase, puis récupérez les traductions dans Figma.

    Si cette option est activée, des balises HTML sont automatiquement ajoutées pour préserver la mise en forme au sein du texte. Elles sont prises en charge dans l’aperçu en contexte du TMS lorsque vous travaillez sur des tâches synchronisées depuis Strings. Les balises de mise en forme HTML apparaissent dans l’éditeur Strings et dans les traductions exportées puis récupérées dans Figma.

    Désactivez cette option si la mise en forme enrichie n'est pas nécessaire pour éviter des ajustements manuels.

    Le paramètre s'applique au niveau du fichier et affecte tous les collaborateurs travaillant dans le fichier. Cette option est mémorisée pour les nouveaux fichiers.

Pour les calques , les actions suivantes sont disponibles dans le menu à trois points Plus correspondant :

  • Sélectionnez Afficher les détails de la clé pour afficher/modifier la description de la clé dans Phrase Strings ou définir une limite de caractères pour la clé. Toute modification enregistrée dans la fenêtre Détails de la clé apparaîtra dans la barre latérale de l'éditeur Strings après l'actualisation de la page de l'éditeur.

    Astuce

    Sélectionnez plusieurs clés dans l'onglet  Transférer le contenu vers Phrase et utilisez l'action groupée Définir une limite de caractères pour définir une limite de caractères pour toutes les clés sélectionnées en une seule fois.

  • Sélectionnez Ouvrir la clé dans l'éditeur pour accéder à la clé correspondante dans l'éditeur Strings.

  • Sélectionnez Déconnecter le contenu de Phrase Strings pour déconnecter le calque d'une clé existante.

Gérer le contenu dupliqué

Lors de l’envoi du contenu, les calques dont le texte est identique génèrent plusieurs clés contenant ce même texte dans Strings. Les utilisateurs peuvent choisir comment gérer le contenu dupliqué dans la fenêtre Transférer le contenu vers Phrase :

  • Sélectionnez Continuer sans fusionner si la création de plusieurs clés avec du contenu dupliqué est intentionnelle.

  • Pour fusionner certains contenus dupliqués en une seule clé, suivez ces étapes :

    1. Sélectionnez deux clés ou plus dans la liste et cliquez sur Fusionner Fusionner dans une clé...

      Une liste déroulante contenant les clés disponibles pour la fusion s'affiche.

    2. Sélectionnez la clé dans laquelle fusionner le contenu dupliqué.

      La clé sélectionnée est signalée par une icône de fusion bleue Fusionner dans une clé dans la fenêtre Transférer le contenu vers Phrase.

    3. Cliquez sur Continuer, puis confirmez en sélectionnant Fusionner et envoyer dans la fenêtre contextuelle Fusionner le contenu dupliqué.

      Le contenu dupliqué est fusionné en une seule clé, et tous les calques associés sont connectés à cette clé.

  • Pour fusionner une partie ou la totalité du contenu dupliqué dans la première clé de la liste, suivez ces étapes :

    1. Sélectionnez plusieurs clés ou toutes les clés de la liste et cliquez sur Fusionner Fusionner tous les doublons dans la première clé.

    2. Cliquez sur Continuer, puis confirmez en sélectionnant Fusionner et envoyer dans la fenêtre contextuelle Fusionner le contenu dupliqué.

      Le contenu dupliqué est fusionné en une seule clé, et tous les calques associés sont connectés à cette clé.

    Cette option est utile pour les fichiers volumineux comportant de nombreux doublons : elle permet de tous les fusionner dans la première clé de la liste en une seule opération, plutôt que de les traiter individuellement.

La duplication d'un cadre ou d'un calque de texte dans Figma duplique également toute connexion existante à une clé Phrase Strings. Si le calque dupliqué est réutilisé pour un nouveau texte sans rapport et envoyé sans être déconnecté au préalable, l'envoi met à jour le texte source de la clé existante au lieu d'en créer une nouvelle. La mise à jour du texte source d’une clé ne supprime ni ne met à jour les traductions dans les langues cibles déjà enregistrées pour cette clé. Si vous récupérez ensuite les traductions dans le calque, vous obtenez celles associées à l’ancien contenu, et non au nouveau texte envoyé.

Avant d’envoyer le contenu d’un cadre ou d’un calque de texte dupliqué ou réutilisé, vérifiez dans l’onglet Transférer le contenu vers Phrase si le calque est déjà connecté à une clé. Si le calque est déjà connecté à une clé et que le nouveau texte n’a aucun rapport avec le contenu précédent, déconnectez-le avant l’envoi afin que le plugin crée une nouvelle clé au lieu d’écraser la clé existante.

Exclusion automatique des calques

Le paramètre Exclure automatiquement les calques retire de l’onglet Transférer le contenu vers Phrase les calques de texte dont le nom commence par un préfixe défini. Lorsque ce paramètre est activé, tout calque dont le nom commence par _ ou . est automatiquement exclu.

Le paramètre est désactivé par défaut et s'applique par fichier. Il est activé pour tous les calques nommés dans ce fichier jusqu'à ce qu'il soit désactivé.

Les exclusions persistent entre les sélections. Pour les composants, si les calques du composant sont préfixés et que Auto-exclude layers est activé, les designs qui réutilisent ce composant héritent de l'exclusion.

Pour exclure automatiquement les calques préfixés de Push :

  1. Dans Figma, préfixez les calques de texte à exclure avec _ ou .. Cela peut également être effectué par lot.

  2. Ouvrez Plugin settings et activez Auto-exclude layers.

Configurer la dénomination des clés

La section Key naming des paramètres du plugin Setup_gear.png permet de configurer la convention de dénomination des clés connectées.

Pour personnaliser les noms de clés dans Figma, suivez ces étapes :

  1. Cliquez sur Enable smart key naming dans les paramètres Key naming.

  2. Sélectionnez Work with key names in Figma.

    Remarque

    Si Synchronize text layer names with keys est activé, les noms de clés sont générés automatiquement en fonction des noms des calques de texte.

  3. Dans le champ Key name generation, saisissez du texte pour définir une convention de dénomination personnalisée des clés :

    • Si nécessaire, cliquez sur Available macros pour sélectionner l’une des macros prises en charge et générer automatiquement les noms de clés.

      Plusieurs macros peuvent être sélectionnées pour composer le nom de la clé.

    • Vous pouvez combiner du texte libre et des macros dans le champ Key name generation.

      Cliquez sur Examples pour afficher les exemples prédéfinis et en choisir un.

  4. Si nécessaire, sélectionnez une option de mise en forme dans la liste déroulante Formatting convention pour modifier le texte en conséquence et supprimer les espaces.

Lors de l’envoi de contenu vers Phrase Strings, appliquez la nouvelle convention de dénomination aux clés déjà connectées de l’une des manières suivantes :

  • Cliquez sur l’icône d’actualisation Refresh List en bas du tableau.

  • Sélectionnez les clés concernées, puis cliquez sur Regenerate key names en haut du tableau.

Macros disponibles

Macro

Description

{file_name}

Le nom du fichier Figma

{page}

La page Figma où la clé est identifiée

{parent_section}

La section de plus haut niveau dans l'arborescence de la page

{nearest_section}

La section la plus proche du calque de texte dans l'arborescence de la page

{frame}

Le cadre où la clé est identifiée

{parent_group}

Le groupe de plus haut niveau dans l'arborescence de la page

{nearest_group}

Le groupe le plus proche du calque de texte dans l'arborescence de la page

{component}

Le nom du composant Figma où la clé est située. Seuls les composants sources sont pris en compte.

{element_name}

Le nom du calque de texte

{element_content}

Le contenu du calque de texte

{random}

Une courte empreinte de hachage unique générée aléatoirement

Remarque

Lorsque Synchronize text layer names with keys est activé, le champ du nom de clé reprend toujours le nom actuel du calque de texte Figma. Figma peut renommer un calque de texte de lui-même, par exemple lorsqu’une variante de composant est remplacée ou que l’état d’une instance imbriquée change. Si plusieurs calques de texte appartiennent à un composant partagé et réutilisé et que les calques individuels n'ont jamais reçu de noms uniques, tous ces calques portent le même nom Figma sous-jacent. Lorsque ce paramètre est activé, tous les calques concernés affichent le même nom générique, qui finit par être envoyé vers Phrase Strings et écrase les noms de clés corrects.

Pour rétablir les noms de clés corrects après ce problème :

  1. Ouvrez les paramètres du plugin (icône d'engrenage) et désactivez Synchronize text layer names with keys pour empêcher les changements de noms de calques d'écraser les noms de clés.

  2. Dans l'onglet Push, sélectionnez les calques concernés et utilisez l'action par lots Sync keys pour redonner aux clés dans Figma les noms stockés dans Phrase Strings.

  3. Vérifiez un échantillon des calques concernés pour confirmer que les noms corrects ont été restaurés.

N'envoyez pas les calques concernés avant d'avoir terminé les deux premières étapes. Si vous envoyez les calques alors que Update key names in Phrase Strings est activé et que le problème n'est pas résolu, les noms incorrects seront enregistrés dans le projet Phrase Strings.

Connecter ou déconnecter des clés

Lors de l'envoi de contenu, les utilisateurs peuvent connecter des calques à des clés existantes dans Phrase Strings ou en générer de nouvelles.

Sélectionnez l'onglet Connect keys pour afficher un aperçu des clés connectées et déconnectées.

Les clés déjà connectées sont identifiées par une icône de lien Connected Key dans la colonne Key name. Si nécessaire, sélectionnez le projet, la branche (si utilisée) et la langue, ou cliquez sur l'icône de recherche pour trouver le contenu souhaité.

Sélectionnez Connect keys pour connecter en masse toutes les clés non liées dans l'onglet. Pour connecter ou déconnecter des clés individuelles, cliquez sur l'icône correspondante à droite de l'entrée concernée.

La duplication ou la copie d'un cadre Figma copie également les associations existantes entre ses calques et les clés. Si le cadre d'origine était associé à des clés d'un autre projet Phrase Strings, les calques dupliqués restent liés aux clés de ce projet au lieu d'être associés à celles du projet souhaité. Si les mêmes paramètres régionaux ne sont pas configurés dans le projet d'origine, la récupération du contenu dans Figma échoue sans message d'erreur pour ces paramètres régionaux sur les calques concernés.

Pour corriger les calques concernés, ouvrez l'onglet Connect keys, sélectionnez le bon projet, sélectionnez le calque de texte concerné sur le canevas, recherchez le contenu et cliquez sur Connect pour la clé correspondante. Il n'est pas nécessaire de dissocier d'abord le calque de sa clé précédente, car un calque peut être associé à une clé différente pour chaque projet.

Certains comptes disposent d'une option « Use new connect view (beta) » dans le panneau des paramètres du plugin. Lorsque cette option est activée, sélectionnez tous les calques concernés en une seule fois sur le canevas, ouvrez Connect keys et utilisez l'action groupée Connect by content pour les reconnecter en une seule opération plutôt qu'individuellement.

Remarque

L'option permettant de déconnecter des clés individuelles est également disponible dans l'onglet Push content to Phrase.

Nouvelle vue de connexion (bêta)

La nouvelle vue répertorie les calques de texte de la sélection actuelle et leur état de connexion dans un tableau unique, à la place de l'ancienne liste organisée par clés.

Remarque

Redémarrez le plugin avant d'activer la version bêta pour vous assurer que la dernière version est chargée.

Pour activer l’option New connect view :

  1. Ouvrez le plugin et cliquez sur l'icône Settings.

  2. Sous Plugin settings, activez Use new connect view (Beta).

  3. Ouvrez Connect keys pour voir la liste du contenu connecté.

L'ancienne vue de connexion reste disponible. Désactivez Use new connect view dans les paramètres du plugin pour revenir en arrière.

Pour connecter un seul calque, sélectionnez-le pour ouvrir une fenêtre avec deux onglets :

  • Suggestions : affiche les clés dont le nom correspond exactement et les clés dont le contenu de traduction correspond.

  • Search : permet de rechercher toutes les clés par nom ou par contenu.

Pour agir sur plusieurs calques, sélectionnez-les pour faire apparaître une barre d'actions groupées :

  • Connecter par nom de clé : connecte les calques aux clés dont le nom correspond exactement.

  • Connecter par contenu : connecte les calques aux clés dont le contenu de traduction correspond.

  • Déconnecter les calques : supprime les connexions des calques sélectionnés.

Ignorer les calques correspondant à plusieurs clés

L’option Ignorer les calques correspondant à plusieurs clés détermine comment Connecter par contenu traite les calques dont le texte correspond à plusieurs clés.

Pour activer l'option :

  1. Ouvrez le plugin et accédez à l'onglet Connecter.

  2. Cliquez sur Menu « Plus » dans la barre de navigation pour ouvrir les options d’affichage.

  3. Activez Ignorer les calques correspondant à plusieurs clés.

Lorsque cette option est activée, tout calque correspondant à plusieurs clés est ignoré lors de l’opération Connecter par contenu et reste déconnecté afin de permettre une vérification manuelle.

Bilan après l’action

Après chaque exécution par lots de l’action Connecter par contenu ou Connecter par nom de clé, une fenêtre affiche les résultats :

  • Nombre de calques connectés

  • Ignoré — aucune correspondance trouvée

  • Ignoré — correspondances multiples (affiché lorsque l’option Ignorer les calques correspondant à plusieurs clés est activée)

Cliquez sur Afficher les calques non connectés pour limiter le tableau aux calques qui nécessitent encore une intervention, ou sur Terminé pour fermer la fenêtre de résultats.

Gérer les clés plurielles

Définir un calque de texte comme clé plurielle le connecte aux formes plurielles de cette clé dans Phrase Strings. Pour une clé plurielle, la colonne Contenu affiche, à la place du contenu de la clé, un menu déroulant permettant de sélectionner une forme parmi celles disponibles pour la langue sélectionnée, par exemple one et other. Les langues dont les règles de pluriel sont plus complexes, comme le polonais, proposent jusqu'à cinq formes.

Le menu déroulant apparaît dans les onglets Envoyer le contenu vers Phrase et Extraire le contenu vers Figma.

Pour prévisualiser une forme plurielle sur le canevas :

  1. Dans le tableau de contenu, localisez la clé plurielle.

  2. Cliquez sur le menu déroulant de sélection de forme dans la colonne Contenu et sélectionnez la forme plurielle à prévisualiser.

  3. Phrase Strings charge la traduction correspondante dans le calque pour la prévisualiser sur le canevas

L’envoi d’une clé plurielle vers Phrase Strings suit la même procédure que pour toute autre clé et ne met à jour que la traduction de la forme sélectionnée.

La forme plurielle sélectionnée est mémorisée par calque, par projet et par branche. La sélection persiste d'une session à l'autre.

Extraire les traductions

Une fois les traductions terminées, sélectionnez les calques ou cadres Figma pour lesquels extraire les traductions et cliquez sur l'onglet Extraire le contenu vers Figma.

Les utilisateurs peuvent sélectionner le projet, la branche (si elle est utilisée) et les langues du contenu à extraire. Les balises ne peuvent pas être rapatriées dans Figma.

Pour gérer de longues listes de noms de clés, utilisez le menu déroulant Trier par Filtre de tri pour choisir Noms de clés incomplets en premier et corriger les éventuels problèmes. Si nécessaire, sélectionnez des clés spécifiques et cliquez sur Exclure les calques en haut du tableau pour supprimer ces calques du plugin.

Remarque

L'option de tri sélectionnée sera mémorisée pour les sessions futures.

Cliquez sur le menu Options d’affichage Menu « Plus » pour choisir comment afficher le contenu extrait dans Figma :

  • Créer une nouvelle page par langue

    Sélectionnée par défaut. Lors de l'extraction pour plusieurs langues, une page Figma distincte est créée pour chaque langue sélectionnée, incluant tous les calques de la page.

    Remarque

    Dans Figma Buzz, l'option Créer une nouvelle ligne avec le contenu traduit est affichée.

  • Créer une page unique avec toutes les langues

    Crée une seule page et dispose le contenu traduit sélectionné côte à côte dans des colonnes propres à chaque langue. Cette option se concentre uniquement sur la sélection active plutôt que de dupliquer toute la page Figma.

    Recommandé pour les fichiers volumineux afin d’améliorer les performances d’extraction et d’éviter d’augmenter inutilement la taille du fichier.

  • Remplacer le texte des calques par les traductions

    Le texte des calques sélectionnés sera remplacé par les traductions, et les calques seront mis à jour dans la zone de travail.

    Cette option est automatiquement désactivée lors de l'extraction pour plusieurs langues.

  • Afficher les noms des clés au lieu du contenu

    Désactivée par défaut. Lorsque cette option est activée :

    • Les noms des clés sont extraits et affichés au lieu du contenu traduit.

    • La sélection d'une langue pour le contenu extrait n'est plus possible.

  • Prévisualiser le contenu dans la langue sélectionnée

    Le paramètre sera mémorisé pour les sessions futures.

    • Si cette option est désactivée, la colonne Contenu affiche directement le contenu des calques sélectionnés.

    • Lorsque cette option est activée, la colonne Contenu affiche un aperçu du contenu dans la langue sélectionnée pour les calques connectés.

      • Pour les calques déconnectés, activez l'option Connecter avec des clés existantes pour afficher un aperçu dans la langue sélectionnée. Si une clé portant le même nom existe dans les données extraites, le contenu de cette clé est utilisé comme aperçu.

    Cette option est automatiquement désactivée lors de l'extraction pour plusieurs langues.

  • Connecter avec des clés existantes

    Définissez la manière dont les calques déconnectés sont traités lors de l’extraction des données vers Figma. Le paramètre sera mémorisé pour les sessions futures.

    • Lorsque cette option est activée, le système vérifie si une clé portant le même nom existe dans les données extraites.

      Si une correspondance est trouvée :

      • Les calques déconnectés sont connectés aux clés correspondantes.

      • Le contenu des calques est mis à jour avec le contenu extrait des clés existantes.

    • Si cette option est désactivée, les calques déconnectés ne sont pas mis à jour, même si des clés correspondantes existent dans les données extraites.

Vérifier le statut de traduction

La fonctionnalité Vérifier le statut de traduction permet de déterminer si les calques de texte de la sélection actuelle disposent déjà de traductions dans les langues cibles sélectionnées, avant d’extraire le contenu vers Figma. La vérification s'effectue sur toutes les clés connectées de la sélection.

Pour vérifier le statut de traduction

  1. Dans l’onglet Extraire le contenu vers Figma, sélectionnez les langues cibles à vérifier.

  2. Cliquez sur Vérifier le statut de traduction.

    La page Statut de traduction affiche, pour chaque langue, le nombre de clés traduites, partiellement traduites et non traduites dans la sélection actuelle.

    Cliquez sur Voir les détails à côté d'une langue pour ouvrir une répartition des clés connectées pour cette langue. Utilisez les filtres Tout, Traduites et Non traduites pour affiner la liste.

Si le contenu est correctement extrait vers Figma, la fenêtre Extraction terminée s'affiche avec un résumé des calques mis à jour.

Lors de l'extraction pour plusieurs langues, le bouton Ouvrir la clé dans l'éditeur ouvre la clé avec la langue par défaut du projet comme langue source.

Remarque

Si une police utilisée dans la conception n'est pas installée localement, le plugin ne peut pas mettre à jour les calques de texte concernés avec les traductions extraites. Lorsque cela se produit, une erreur « The font [X] could not be loaded » s'affiche, où [X] est le nom de la police manquante. Installez localement toutes les polices signalées dans ce message d'erreur, puis récupérez à nouveau le contenu.

Figma Buzz

Figma Buzz est un outil qui permet aux designers spécialisés dans l’identité de marque et aux équipes marketing de créer à grande échelle des visuels respectant cette identité, directement dans l’écosystème Figma. Il comprend un système de modèles, un éditeur de design simplifié, des fonctionnalités de création de ressources par lots et de retouche assistée par l’IA.

Le plugin Phrase Strings pour Buzz permet de localiser le contenu textuel directement dans Buzz en offrant les mêmes fonctionnalités que dans l'intégration Figma Design :

Remarque

La prévisualisation en direct n'est pas prise en charge.

Le plugin est disponible dans le menu Plugins de Buzz. Une fois activé, le plugin peut être enregistré pour une utilisation ultérieure et exécuté sur le design sélectionné en ouvrant le plugin dans une fenêtre modale depuis la barre latérale de Figma Buzz. Les calques de texte sont automatiquement détectés et affichés dans le plugin.

Le contenu du design peut ensuite être envoyé vers un projet Strings connecté pour traduction. Après la traduction, les utilisateurs peuvent récupérer le contenu localisé dans Buzz, ce qui crée une nouvelle ligne contenant la version traduite du design.

L’option Upload Figma preview et la sélection de la langue cible avant l’envoi des clés ne sont pas disponibles dans Buzz. Lors de l'envoi de clés depuis Buzz, toutes les langues cibles configurées dans le projet Strings sont utilisées automatiquement.

Cet article vous a-t-il été utile ?
★ ★ ★ ★ ★

Sorry about that! In what way was it not helpful?

The article didn’t address my problem.
I couldn’t understand the article.
The feature doesn’t do what I need.
Other reason.

Note that feedback is provided anonymously so we aren't able to reply to questions.
If you'd like to ask a question, submit a request to our Support team.
Thank you for your feedback.